Напишите программу. дана последовательность чисел, количество чисел неизвестно, оканчивается 0. найти сумму и количество чисел, оканчивающихся на 7 и кратных 3.

Nastena11102003 Nastena11102003    3   17.09.2019 10:00    1

Ответы
danyabro1 danyabro1  07.10.2020 21:37
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqIntegerWhile(t->t<>0).Where(t->(t mod 10=7) and (t mod 3=0))
      .ToArray;
  Writeln('Сумма ',a.Sum,', количество ',a.Count)
end.

Пример
33 -77 117 27 -15 0
Сумма 144, количество 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика