Напишите программу )) дан массив действительных чисел.среди них есть равные .найти первый максимальный элемент массива и заменить его нулём

Chvik Chvik    3   08.03.2019 15:00    108

Ответы
Valensia59 Valensia59  24.05.2020 06:53

Program num1;
Uses crt;
Var x:array[1..10] of real;
max:real;
i : integer;
Begin
clrscr;
for i:=1 to 10 do
begin
write('x[',i,']=');readln(x[i])
end;
max:=x[1];
for i:=1 to 10 do
if x[i]>=max then max:=x[i];
Writeln('Max=',max:3:1);
for i:=1 to 10 do
if x[i]=max then begin x[i]:=0;break end;
for i:=1 to 10 do write(' *',x[i]:3:1,'* ');
End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика