Напишите программу. дан массив действительных чисел размерности n. получить удвоенную сумму всех положительных элементов массива и удвоенное произведение всех отрицательных элементов массива, расположенных после максимального члена последовательности.

mishaikatya mishaikatya    3   04.10.2019 10:11    8

Ответы
вика28121 вика28121  17.08.2020 07:51

const n=10;

var a:array [1..n] of real;

i,mi:integer;

s,m,p:real;

begin

write('Массив: ');

for i:=1 to n do

begin

a[i]:=random*20-10;

write(a[i]:0:3,' ');

if a[i]>0 then s:=s+2*a[i];

end;

writeln;

m:=a[1];

mi:=1;

for i:=1 to n do  if a[i]>m then

begin

m:=a[i];

mi:=i

end;

p:=1;

for i:=mi to n do  if a[i]<0 then p:=p*2*a[i];

writeln ('Удвоенная сумма всех положительных элементов массива: ',s:0:3);

if p=1 then writeln ('Отрицательных чисел после максимального элемента нет')

else writeln ('Удвоенное произведение всех отрицательных элементов массива, расположенных после максимального элемента: ',p:0:3);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика