Напишите программу, чтобы с её можно было найти наибольший общий делитель произвольных десяти целых двузначных чисел (на языке паскаль)

gameadventgary gameadventgary    1   04.10.2019 04:10    25

Ответы
papa42 papa42  09.10.2020 18:47

на яве мог бы

ПОКАЗАТЬ ОТВЕТЫ
суперМозг777 суперМозг777  13.01.2024 05:32
Конечно! Вот программа на языке Паскаль, которая позволяет найти наибольший общий делитель произвольных десяти целых двузначных чисел:

```
program Наибольший_общий_делитель;
var
a, b, GCD, temp: integer;

function НОД(a, b: integer): integer;
begin
while b <> 0 do
begin
temp := b;
b := a mod b;
a := temp;
end;

НОД := a;
end;

begin
writeln('Введите два десятичных двузначных числа:');
readln(a, b);

GCD := НОД(a, b);

writeln('Наибольший общий делитель чисел ', a, ' и ', b, ' равен ', GCD);
end.
```

Теперь разберем программу шаг за шагом:

1. Здесь мы объявляем переменные: `a`, `b`, `GCD` и `temp`. `a` и `b` будут использованы для ввода двузначных чисел, `GCD` будет хранить значение наибольшего общего делителя, а `temp` будет использоваться для временного хранения значения при обмене.

2. Мы объявляем функцию `НОД`, которая будет использоваться для вычисления наибольшего общего делителя. В строчках 10-13 мы используем алгоритм Евклида - в цикле мы находим остаток от деления `a` на `b`, затем присваиваем `b` значение `a mod b` и `a` значению `temp`. Этот процесс повторяется, пока `b` не станет равным нулю. После этого `a` будет содержать наибольший общий делитель, и мы возвращаем это значение.

3. Затем мы просим пользователя ввести два десятичных двузначных числа. Это делается с помощью `readln`, где `a` и `b` будут получать значения, введенные пользователем.

4. Мы вызываем функцию `НОД` и присваиваем её результат переменной `GCD`.

5. Наконец, мы выводим результат на экран с помощью `writeln`, объединяя текст и значения переменных с помощью оператора `+`.

Вот и все! Теперь программа способна находить наибольший общий делитель произвольных двузначных чисел.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика