напишите программу 1) Последовательность изменяется по закону 2,10,18... Сколько элементов последовательности надо взять, чтобы их сумма была больше 100 2) С клавиатуры вводится 20 чисел. Определите произведение этих чисел, количество положительных, сумму отрицательных элементов заранее

настя7579 настя7579    1   14.01.2022 05:41    3

Ответы
supermichail29 supermichail29  14.01.2022 06:00

Решение на паскале.

Объяснение:

Первая задача:

var summa, kolichestvo : integer;

 begin

   summa := 2;

   while summa <= 100 do

   begin

     summa := summa + 8;

     kolichestvo := kolichestvo + 1;

   end;

   writeln('Количество = ', kolichestvo);

 end.

Вторая задача:

var a : array[1..20] of integer;

   kolpol, sumot, i : integer;

begin

 for i:=1 to 20 do

   Read(a[i]);

 for i := 1 to 20 do

   if a[i] >= 0 then

     kolpol := kolpol +1

   else

     sumot := sumot + a[i];

 writeln('Количество положительных = ', kolpol);

 writeln('Сумма отрицательных = ', sumot);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика