tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программный код
Напишите программный код к следующей : организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт нуль. после ввода нуля, показать на экране количество чисел, которые были введены, их общую сумму и среднее арифметическое.!
маша4737
2 07.04.2019 10:29
5
Ответы
hmelova
28.05.2020 19:14
Program mm;
var sum, sred, a, n:Real;
begin
sum:=0;
a := 0;
Read(n);
while n<>0 do begin
a:=a + 1;
sum := sum + n;
sred := sum/a;
Read(n);
end;
WriteLn('Colichestvo:', a);
WriteLn('Spednee:', sred);
WriteLn('Summa:', sum);
end.
Вот решение.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
EvaBonarmailmailru
26.10.2021 06:57
Сообщение, состоящее из 56 символов, записано буквами алфавита, представленного 128 символами. Какое количество информации оно несет?...
doagetonya
02.08.2019 11:00
Что токое даоичный код как им пользоваться и что надо сделать чтоб его получить? ?...
кукипро
02.08.2019 11:00
Решить : к=1024×512 i=1.5 мб i=? n=?...
пахан50
16.02.2021 18:29
Как это сделать урок информатика ...
таня44448
16.02.2021 18:29
Задание на Phyton Перемножить все четные числа в диапазоне пользователя. Перемножить все не четные числа в диапазоне пользователя. Записать в массив все положительные/отрицательные...
nastyakolomiec1
16.02.2021 18:29
Створити свій клас Car() для опису автомобілів з 3 атрибутами. Надо зделать очень Потом буду и Вам...
nastua89723
02.10.2019 01:10
Создать 3 файла формата html и 1 файл формата css в одной папке так, чтобы каждому html соответствовал имя, фамилия, отчество. то есть на одном сайте написано только имя, на другом...
MrCrative25
02.10.2019 01:10
Сколько цифр содержит пятеричная запись десятичного числа 120...
rukonya2009
05.08.2019 16:50
)) составить блок-схему. вводится три числа. найти сумму тех чисел, которые делятся на 5. если таких чисел нет, то вывести error....
vikimeis2006
05.08.2019 16:50
Компьютер является универсальным автоматическим устройством для работы с чем?...
Популярные вопросы
1.каким общим свойством вещества 2. какова роль белков в организме 4. как можно...
3
Перечислите равнины россии. перечислите низменности россии. перечислите горы...
2
Подчеркни родственные слова в каждой скороговорке: проворонила ворона воронёнка.перепел...
3
Xкг яблок разложили в 5 ящиков. сколько кг яблок положили в 13 таких ящиков...
3
Мне нужно дописать так,как я (вы) считаете: я спытау чалавекаю якi прйшоу праз...
3
Вмагазин пять мешков риса по 40 кг в каждом и 5 мешков пшена по 35 кг в каждом....
3
Решите систему неравенств 4х-21 0 х+3,5 0...
1
Почему взаимоотношений мани и дубровского завершилась драматически? виноваты...
2
Назови вещества из которых можно зделать вазу?...
3
58 , напишите мини сочинение на казахском на тему менің түған кунім...
1
var sum, sred, a, n:Real;
begin
sum:=0;
a := 0;
Read(n);
while n<>0 do begin
a:=a + 1;
sum := sum + n;
sred := sum/a;
Read(n);
end;
WriteLn('Colichestvo:', a);
WriteLn('Spednee:', sred);
WriteLn('Summa:', sum);
end.
Вот решение.