tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите цикл на abcpascal.net
Напишите цикл на abcpascal.net который любое число вводит в степень до бесконечности например 2^2=4, 2^3=
ashurovaalbina8
2 07.09.2019 01:20
2
Ответы
Новичок345
06.10.2020 22:12
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var x:=ReadInteger('Введите число:');
var (i,y):=(2,BigInteger(x));
while true do begin
y*=x;
Writeln(x,'^',i,'=',y);
i+=1
end
end.
Пример
Введите число: 2
2^2=4
2^3=8
2^4=16
2^5=32
2^6=64
2^7=128
2^8=256
2^9=512
2^10=1024
2^11=2048
2^12=4096
2^13=8192
2^14=16384
2^15=32768
2^16=65536
2^17=131072
2^18=262144
2^19=524288
2^20=1048576
2^21=2097152
2^22=4194304
2^23=8388608
2^24=16777216
2^25=33554432
2^26=67108864
2^27=134217728
2^28=268435456
2^29=536870912
2^30=1073741824
2^64=18446744073709551616
2^65=36893488147419103232
2^66=73786976294838206464
2^67=147573952589676412928
2^68=295147905179352825856
2^69=590295810358705651712
2^70=1180591620717411303424
2^200=1606938044258990275541962092341162602522202993782792835301376
2^201=3213876088517980551083924184682325205044405987565585670602752
2^202=6427752177035961102167848369364650410088811975131171341205504
2^203=12855504354071922204335696738729300820177623950262342682411008
2^204=25711008708143844408671393477458601640355247900524685364822016
2^205=51422017416287688817342786954917203280710495801049370729644032
2^206=102844034832575377634685573909834406561420991602098741459288064
2^207=205688069665150755269371147819668813122841983204197482918576128
2^208=411376139330301510538742295639337626245683966408394965837152256
2^209=822752278660603021077484591278675252491367932816789931674304512
2^210=1645504557321206042154969182557350504982735865633579863348609024
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
babaevgleb70
28.12.2020 09:05
Акпатрат турлеры кандай? ...
i942627
18.05.2019 23:20
Переведите число с 8-ричной системой в 16-ричную: 2034-? с объяснением !...
kristina763
24.03.2021 14:37
Составить программу вычисления квадратного уравнения ax2+bx+c. Коэффициенты a,b,c вводятся с клавиатуры в питоне....
ФЛЭМЭНКО
10.06.2021 10:59
1. Информационная безопасность – это … A) защищенность информации от любых действий, в результатекоторых она может быть искажена или утеряна, а пользователям нанесен недопустимый...
Сережа8910
10.06.2021 10:36
, где у меня ошибка в Паскаль? program exam_zadll_algorithm; var X1, Xl, l: real; begin ReadLn(X1, l=1..3); M:= X1; for i := 2 to 3 do begin if Xl M then begin end else begin...
Sergei12121
10.06.2021 10:35
сегодня до 11:30! На С++! Один элемент (автомобиль) представляет собой структуру с полями: фамилия владельца, марка автомобиля, требуемая марка бензина, мощность двигателя,...
polinakolesnik4
10.06.2021 10:30
Составить программу нахождения произведения всех чисел из заданного одномерного массива ....
ehidna666
12.08.2019 17:20
Перечислите плюсы и минусы автоматизации деятельности человека...
dssh70
12.08.2019 17:20
Вмассиве из 8 целых чисел переставить максимальный элемент на первое место, а элементы с первого до максимального сдвинуть на одну позицию вправо.!...
artchapyshev
17.06.2019 11:40
Диктант синички для третьего класса...
Популярные вопросы
Решить ,составить обратные и решить. , ...
3
Какой цифрой оканчивается произведение 72×73×74××79?...
3
Учитель принёс 12 книг и раздал их нескольким ученикам по з книги каждоиму...
1
Вуравнении (x²-3x)(x²-3x-4)=12 сделана замена x²-3x=t. укажите квадратное...
3
Написать на языке вот эти предложения тут много красивых мест и я побывала...
2
Проаналізуйте мовлення діда платона. чим ви поясните саме такий добір ним...
2
Сделайте сочинение рассуждение на тему: в чем ценность и особенности карагалинской...
3
Учащихся: 8. по графику зависимости определите коэффициент про-порциональности...
3
Складіть рівняння реакцій за якими можна здійснити такі перетворення cuso4-...
3
Complete the letter using the correct tense form. 7 стр 113 6 класс...
1
// Внимание! Если программа не работает, обновите версию!
begin
var x:=ReadInteger('Введите число:');
var (i,y):=(2,BigInteger(x));
while true do begin
y*=x;
Writeln(x,'^',i,'=',y);
i+=1
end
end.
Пример
Введите число: 2
2^2=4
2^3=8
2^4=16
2^5=32
2^6=64
2^7=128
2^8=256
2^9=512
2^10=1024
2^11=2048
2^12=4096
2^13=8192
2^14=16384
2^15=32768
2^16=65536
2^17=131072
2^18=262144
2^19=524288
2^20=1048576
2^21=2097152
2^22=4194304
2^23=8388608
2^24=16777216
2^25=33554432
2^26=67108864
2^27=134217728
2^28=268435456
2^29=536870912
2^30=1073741824
2^64=18446744073709551616
2^65=36893488147419103232
2^66=73786976294838206464
2^67=147573952589676412928
2^68=295147905179352825856
2^69=590295810358705651712
2^70=1180591620717411303424
2^200=1606938044258990275541962092341162602522202993782792835301376
2^201=3213876088517980551083924184682325205044405987565585670602752
2^202=6427752177035961102167848369364650410088811975131171341205504
2^203=12855504354071922204335696738729300820177623950262342682411008
2^204=25711008708143844408671393477458601640355247900524685364822016
2^205=51422017416287688817342786954917203280710495801049370729644032
2^206=102844034832575377634685573909834406561420991602098741459288064
2^207=205688069665150755269371147819668813122841983204197482918576128
2^208=411376139330301510538742295639337626245683966408394965837152256
2^209=822752278660603021077484591278675252491367932816789931674304512
2^210=1645504557321206042154969182557350504982735865633579863348609024