tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напиши программу, которая
Напиши программу, которая выводит сумму n чисел, введенных пользователем. число n должно так же определяться пользователем. язык с#
Julia13662004
1 21.09.2019 16:00
12
Ответы
kz2388
01.09.2020 20:32
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace 1
{
class Program
{
static void Main(string[] args)
{
bool Mistake = false;
int N = 0;
do
{
Console.Write("Введите количество слагаемых: ");
try
{
N = Convert.ToInt32(Console.ReadLine());
Mistake = false;
}
catch (FormatException)
{
Mistake = true;
Console.Clear();
Console.WriteLine("Неверный формат ввода! Повторите попытку!");
Console.WriteLine();
}
}
while (Mistake == true);
Sum(N);
}
static void Sum(int N)
{
double[] Elements = new double[N];
double Result = 0;
for (int i = 0; i < N; i++)
{
Console.WriteLine();
Console.Write("Введите " + (i + 1) + " число: ");
try
{
Elements[i] = Convert.ToDouble(Console.ReadLine());
}
catch (FormatException)
{
Console.WriteLine("Неверный формат ввода!");
}
}
for (int j = 0; j < N; j++)
{
Result += Elements[j];
}
Console.WriteLine();
Console.Write("Сумма = " + Result);
Console.ReadKey();
}
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Juliana2414
12.11.2020 20:49
я не понимаю я в 7 классе...
viceofficial
12.11.2020 20:49
Електроне спілкування - це...
krasnikovanastoyhpaj
14.02.2020 15:34
1)Приведите пример листинга программа, которая заполняет пустой массив десятью целыми числами, введеными с клавиатуры. 2)Вычислите сумму данных N натуральных чисел. Входные...
JAHGH
14.02.2020 15:30
Какой коврик для мыши лучше выбрать черный или с раскраской? Будет ли влиять цвет на результат скорости игровой мыши...
YlankinaAnastasiya
31.08.2019 05:50
Найти среднее арифметическое 10чисел, введенных с клавиатуры (паскаль)...
olyamin0
31.08.2019 06:00
Написать программу в pascal. найдите сумму всех целых чисел [a; b]заранее ....
наташа978
31.08.2019 06:00
Полная информация про книжный фонд библиотеки помещена в : закодированном алгоритме,алфавитном каталоге,активном образе,мусорной корзине....
faceface96
31.08.2019 06:00
Подсчитать, сколько памяти понадобится для хранения сообщения: «через 5 лет я окончу школу: )», если используется кодировка кои-8. ответ: 23 байта 28 бит 224 бит 184 бита...
ПНШосннс
31.08.2019 06:00
Подсчитать, сколько памяти понадобится для хранения сообщения: «в юном месяце апреле…», если используется кодировка ascii (кавычки не считать) ответ: 23 байта 184 байта 23...
rgn123
31.08.2019 06:00
Племя информатиков использует 37 символьный алфавит, а племя 24 символьный. вожди племен послали друг другу письма, в письме племени было 60 букв, вес сообщений оказался...
Популярные вопросы
Вмарте цех увеличил выпуск продукции на 10% по сравнению с февралем. в...
3
Укажите номера неверных утверждений. 1) диагонали ромба всегда перпендикулярны....
2
Постройте треугольник по трем сторонам а; =6см ,б=7см , с=5см...
2
Чему равна масса соли,образовавшейся при нагревании 20 гр оксида меди...
2
Одна из пород кур отличается ногами - доминантный признак. этот ген влияет...
1
Расставьте коэффициенты в схемах методом электронного . укажите окислитель...
1
Нужно написать мини-сочинение на тему я люблю гулять в парке...
1
Богатство и выразительность глаголов в языке....
2
№1на развитие каких отраслей хозяйства поволжья повлияла р.волга? 1энергетики...
1
Германское племя, захватившее рим в 5-ом веке. нужен ответ! !...
3
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace 1
{
class Program
{
static void Main(string[] args)
{
bool Mistake = false;
int N = 0;
do
{
Console.Write("Введите количество слагаемых: ");
try
{
N = Convert.ToInt32(Console.ReadLine());
Mistake = false;
}
catch (FormatException)
{
Mistake = true;
Console.Clear();
Console.WriteLine("Неверный формат ввода! Повторите попытку!");
Console.WriteLine();
}
}
while (Mistake == true);
Sum(N);
}
static void Sum(int N)
{
double[] Elements = new double[N];
double Result = 0;
for (int i = 0; i < N; i++)
{
Console.WriteLine();
Console.Write("Введите " + (i + 1) + " число: ");
try
{
Elements[i] = Convert.ToDouble(Console.ReadLine());
}
catch (FormatException)
{
Console.WriteLine("Неверный формат ввода!");
}
}
for (int j = 0; j < N; j++)
{
Result += Elements[j];
}
Console.WriteLine();
Console.Write("Сумма = " + Result);
Console.ReadKey();
}
}
}