Написать в паскаль abc 1) напишите программу, перемножающую целые числа без использования операции < < * > > . например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m++m). 2) напишите программу возведения числа в целую степень. число и степень запрашивайте у пользователя.

lora1981 lora1981    2   28.05.2019 12:00    2

Ответы
bogdankavolev9 bogdankavolev9  25.06.2020 22:57
Опишу только момент, в котором вся суть, т.е. без ввода данных и т.д.:
...
for i:=1 to (на сколько надо умножить) do
k:=k+a {k-итоговая сумма, перед циклом к=0, в конце к<>0; a-вводимое число}
...
таким же образом поступаем и с умножением
ПОКАЗАТЬ ОТВЕТЫ
MATVEI235 MATVEI235  25.06.2020 22:57
Uses crt;
var x,y,pr,i:integer;
begin
     pr:=0;
     write('1 множитель:'); readln(x);
     write('2 множитель:'); readln(y);
     for i:=1 to x do
         pr:=pr+y;
     writeln('произведение:',pr);
end.
---
uses crt;
var x,y,st,i:integer;
begin
     st:=1;
     write('число:'); readln(y);
     write('степень:'); readln(x);
     for i:=1 to x do
         st:=st*y;
     writeln('результат::',st);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика