tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программы в
Написать программы в паскале • дан массив из n вещественных чисел. поменять местами последний и минимальный элементы массива. • дан массив из n целых чисел. найти номер первого элемента, который равен количеству элементов, кратных 3.
KriSha11
2 07.06.2019 01:30
3
Ответы
Enotik0372
06.07.2020 23:06
Program task1;
const
n = 10;
var
a :array [1..n] of real;
i, j :integer;
min, k :real;
begin
for i:= 1 to n do
readln(a[i]);
min:= a[1];
for i:= 1 to n do
if a[i] < min then
begin
min:= a[i];
j:= i;
end;
k:= a[n];
a[n]:= a[j];
a[j]:= k;
end.
program task2;
const
n = 10;
var
a :array [1..n] of integer;
i, j, kol :integer;
begin
for i:= 1 to n do
readln(a[i]);
kol:= 0;
for i:= 1 to n do
if a[i] mod 3 = 0 then
inc(kol);
for i:= 1 to n do
if a[i] = kol then
begin
j:= i;
break;
end;
writeln(j);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
comeback92
13.05.2020 09:59
Найди периметр комнаты шириной 5 м длина 10 м расписать по стандартной постановке задачи...
НастяО11
08.05.2020 21:32
Какой это цикл? 1. Цикл с условием окончания работы (цикл ДО) 2. Цикл с заданным числом повторений (цикл ДЛЯ) 3. Цикл с условием продолжения работы (цикл ПОКА)...
дима2195
08.05.2020 21:33
Что, по вашему мнению, стимулировало развитие техноло-гий обработки текстовой информации? Как это связано спонятием «безбумажные технологии»? Наступит ли такоевремя,...
annasolovey63
08.05.2020 21:34
Цикл имеет важную особенность, в нем тело цикла всегда выполняется хотя бы один раз, так как первая проверка условия происходит тогда, когда тело цикла уже выполнено....
Cepёжka
08.05.2020 21:34
3) Все 5-буквенные слова, составленные из букв А, К, Р, У, записаны в алфавитном порядке. Вот начало списка: 1. 2. К 3. Р 4. У 5. АААКА …… Какое количество слов находятся...
utyak717
08.05.2020 21:34
Посоветуйте сервера в кс дз по информ скоро здавать...
elenagorodan
08.05.2020 21:34
Что, по вашему мнению, стимулировало развитие техноло-гий обработки текстовой информации? Как это связано спонятием «безбумажные технологии»? Наступит ли такоевремя,...
Cricetinae
08.05.2020 21:38
Информатика Урок 7: Художник: Циклы 4 номер...
natalie1m222
08.05.2020 21:52
Створіть новий файл Python та нове вікно із заголовком “Магазин морозива 2”. Створіть групу перемикачів. Над першою групою створіть напне Оберіть тип морозива”. В групі...
Агент527
08.05.2020 21:52
Оставить алгоритм нахождения площади и периметра для фигуры произвольной...
Популярные вопросы
Найти произведение комплексных чисел: z1=2i z2=3i-1...
2
5 В первом пакете было 28 кг муки. Когда из него отсыпа- 7 3 ли...
2
К каким государствам относится Узбекистан по уровню развития экономики...
2
Решите это задачу в таблицу. (тема: система двух линейных уравнений...
3
На ресунке рещите только быстро...
3
Смесь сухофруктов состоит из 4 частей изюма,7 частей слив и 3 частей...
3
Даны точки пересечения параболы с осями координат. Найдите координаты...
3
Расставьте коэффициенты методом электронного баланса Fe + H2SO4(конц.)...
1
слова подставить надо. В самом низу задание...
1
Довгота точок перетину паралелі 26 градусів південної широти з береговою...
2
const
n = 10;
var
a :array [1..n] of real;
i, j :integer;
min, k :real;
begin
for i:= 1 to n do
readln(a[i]);
min:= a[1];
for i:= 1 to n do
if a[i] < min then
begin
min:= a[i];
j:= i;
end;
k:= a[n];
a[n]:= a[j];
a[j]:= k;
end.
program task2;
const
n = 10;
var
a :array [1..n] of integer;
i, j, kol :integer;
begin
for i:= 1 to n do
readln(a[i]);
kol:= 0;
for i:= 1 to n do
if a[i] mod 3 = 0 then
inc(kol);
for i:= 1 to n do
if a[i] = kol then
begin
j:= i;
break;
end;
writeln(j);
end.