Написать программы на языке python 1. введите с клавиатуры 5 положительных целых чисел. вычислите сумму тех из них, которые делятся на 4 и при этом заканчивается на 6. программа должна вывести одно число: сумму чисел, кратных 4 и оканчивающихся на 6 2.напишите программу для решения следующей . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. необходимо определить максимальную зарегистрированную скорость автомобиля. если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведите «yes», иначе выведите «n0».программа получает на вход число проехавших автомобилей n (1 < n < 30), затем указываются их скорости. значение скорости не может быть меньше 1 и больше 300.программа должна сначала вывести максимальную скорость, затем yes или no.

lordikEgorka lordikEgorka    2   23.03.2019 09:35    113

Ответы
Babka2002 Babka2002  26.05.2020 15:49

А самому, не?

1. def func():

i, summ = 0,0

while i < 5:

 i += 1

 x = int(input())

 if (x % 4 == 0) and (x % 10 == 6):

  summ += x

print(summ)

  func()

2.def speed():

n = int(input())

i = 0

maxSpeed = 0

text = 'NO'

while i < n:

 i += 1

 x = int(input())

 if x < 30:

  text = 'YES'

 elif x > maxSpeed:

  maxSpeed = x

print(maxSpeed, text)

 speed()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика