Написать программу( желательно си++). Дана непустая последовательность литер, оканчивающаяся точкой.Определить, удовлетворяет ли она следующему свойству: последовательность совпадает с каким-то отрезком ряда 0123456789

Andrey720 Andrey720    3   27.10.2020 11:04    11

Ответы
Космос1986 Космос1986  26.11.2020 11:05

#include <iostream>

using namespace std;

int main() {

string s;

string ss("0123456789");

getline(cin, s);

if(s[s.length()-1!='.']) {

 s+=".";

}

string temp;

for(int i = 0; i<ss.length(); ++i) {

 temp+=ss[i];

 if(s.find(temp)!=-1) {

  cout << "yes";

 return 0;

 }

}

cout << "no";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика