Написать программу (желательно на питоне) или на любом языке про температуру
: известны дневные и ночные температуры мая. определить дни, когда перепад
температур был максимальным.

Токаарічіна Токаарічіна    2   15.10.2019 17:22    5

Ответы
KamilyaG KamilyaG  10.10.2020 06:56

Написано на Pascal

var

 Night:array [1..31] of integer ; //Массив с ночными температурами

 Day:array[1..31] of integer; //Массив с дневными температурами

 i,dif: integer;

begin

 dif:=0; // Разница

 for i:=1 to 31 do // Цикл заполняющий дневные и ночные температуры(Тут без отрицательных температур)

 begin  

   Night[i]:=random(30); // Рандомная ночная температура

   Day[i]:=random(30); // Рандомная дневная температура

 end;

 for i:=1 to 31 do // Цикл, который ищет максимальную разницу

   if (Day[i]-Night[i])>=dif then

   begin  

     dif:=Day[i]-Night[i];

   end;

 for i:=1 to 31 do // Цикл, который выводит дни с максимальной разницей

 if dif=(Day[i]-Night[i]) then

 writeln('Разница '+dif+'; '+i+' Мая');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика