Написать программу заполняющую строковой массив с размером 5 с клавиатуры , а затем произвести сложение нечётных элементов массива и из их суммы вычесть сумму чётных элементов

kristina5171 kristina5171    3   20.05.2019 16:33    3

Ответы
AgafAl AgafAl  14.06.2020 05:31

program raf105;

var

 a: array[1..5] of integer;

 x,sum_n,sum_c,res,i: integer;

begin

writeln('Вводите 5 чисел по очереди');

for i:=1 to 5 do

begin

 readln(x);

 if (x mod 2 = 0) and  (x <> 0)

   then sum_c:= sum_c + x;

 if x mod 2 <> 0

   then sum_n:= sum_n + x;

end;

writeln('Вывод: ',sum_n-sum_c);

end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика