tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу: заполнить
Написать программу: заполнить таблицу значений функции y=sqrt((1/2*x-1)+2) с шагом 0,1. значения аргумента берутся из [0; 3,8]. предстоит продумать вопрос вывода результата.
seregasasaas
3 27.06.2019 23:40
4
Ответы
Bluka23
22.07.2020 10:58
Uses Crt;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=3.8 do
begin
y:=sqrt((1/2*x-1)+2);
Writeln(x:3:1,' ',y:10:8);
x:=x+0.1
end;
ReadKey
end.
Результат выполнения программы:
0.0 1.00000000
0.1 1.02469508
0.2 1.04880885
0.3 1.07238053
0.4 1.09544512
0.5 1.11803399
0.6 1.14017543
0.7 1.16189500
0.8 1.18321596
0.9 1.20415946
1.0 1.22474487
1.1 1.24498996
1.2 1.26491106
1.3 1.28452326
1.4 1.30384048
1.5 1.32287566
1.6 1.34164079
1.7 1.36014705
1.8 1.37840488
1.9 1.39642400
2.0 1.41421356
2.1 1.43178211
2.2 1.44913767
2.3 1.46628783
2.4 1.48323970
2.5 1.50000000
2.6 1.51657509
2.7 1.53297097
2.8 1.54919334
2.9 1.56524758
3.0 1.58113883
3.1 1.59687194
3.2 1.61245155
3.3 1.62788206
3.4 1.64316767
3.5 1.65831240
3.6 1.67332005
3.7 1.68819430
3.8 1.70293864
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kopanenkoanutaoyp3as
05.08.2019 18:10
Синформатикой) 1. за 45 секунд был распечатан текст. подсчитать количество страниц в тексте, если известно, что в среднем на странице 50 строк по 75 символов в каждой, скорость...
olesy1945
05.08.2019 18:10
Ой, буду тому доброму человеку, который мне со всем этим! 1. зашифровать данный текст, используя 16-ричные таблицы ascii и ср 866 : принтер 2. дешифровать данный текст, используя...
movamrr
27.09.2019 23:51
Вкачестве объекта исследования выберите объект школа и разработайте информационные модели отражающие точку зрения ученика родителя ученика директора школы для каждой модели...
TOMIRIBOT
29.07.2019 11:50
Написать в кумире. во дворе гуляют кролики и куры (количество и тех и других вводится с клавиатуры). все они здоровы и полноценны. сколько ног топчет двор?...
Fivesecond
24.12.2021 21:29
1. Напишите программу для решения примера (по вариантам). Предусмотрите проверку деления на ноль. Все необходимые переменные пользователь вводит через консоль. Запись |пример|...
People200311
24.12.2021 21:17
за правильное решение. Надо только 1,2 и 5...
ДжудиХопс12345
24.12.2021 21:10
1) F= (AVB) - (BVC) 2) _ (AVBVC)&AVBVC 3) _ _ _ (A&B&B)V (A&A) V(B&C&C) Черточки - это инверсия...
красав4ик007
24.12.2021 21:07
Необходимо описать только процедуру deg(N), которая вычисляет, какой степенью числа 8 является натуральное число N и выводит эту информацию на экран. Если N не степень восьми,...
геймер39
24.12.2021 21:04
Написать программу к решению задачи. Дана строка, содержащая путь к файлу. Выяснить название папки, в которой лежит файл. Пример. вход: C:\Мамины документы\Тесты и контрольные\7кл\годовая...
lineage216
09.02.2021 09:24
с имеющейся в вашем распоряжении программы переводчика переводите на знакомые вам иностранный язык фразу- кроме текстовых процессоров предназначенных для создания обработки...
Популярные вопросы
Есть ли грамматические ошибки в предложениях? А) W?hrend seines Aufenthalts...
1
Berlin-West wieder vereinigt. Berlin ist die deutsche Hauptstadt und gleichzeitig...
2
В предложении есть сложное слово? А) Sie sind in unserem Kindergarten...
2
Продолжите предложение: Aber auf solche Weise gelingt es nicht, die Geschichte...
1
Замените выделенные выражения на синонимичные: Die Weser, der Mittellandkanal...
3
Выберите верный перевод фразы: У нее карие глаза sie hat braune Augen...
3
Предложение является сложносочиненным? А) Seien Sie bitte so freundlich...
2
Установите последовательность слов в предложении: Welches Denkmal in Ihrer...
2
Установите соотношение между репликами диалога: Wie hei?t sie denn? <...
1
Соедините подходящие понятия: Der Bau von Dammen und Deichen < ist auch...
1
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=3.8 do
begin
y:=sqrt((1/2*x-1)+2);
Writeln(x:3:1,' ',y:10:8);
x:=x+0.1
end;
ReadKey
end.
Результат выполнения программы:
0.0 1.00000000
0.1 1.02469508
0.2 1.04880885
0.3 1.07238053
0.4 1.09544512
0.5 1.11803399
0.6 1.14017543
0.7 1.16189500
0.8 1.18321596
0.9 1.20415946
1.0 1.22474487
1.1 1.24498996
1.2 1.26491106
1.3 1.28452326
1.4 1.30384048
1.5 1.32287566
1.6 1.34164079
1.7 1.36014705
1.8 1.37840488
1.9 1.39642400
2.0 1.41421356
2.1 1.43178211
2.2 1.44913767
2.3 1.46628783
2.4 1.48323970
2.5 1.50000000
2.6 1.51657509
2.7 1.53297097
2.8 1.54919334
2.9 1.56524758
3.0 1.58113883
3.1 1.59687194
3.2 1.61245155
3.3 1.62788206
3.4 1.64316767
3.5 1.65831240
3.6 1.67332005
3.7 1.68819430
3.8 1.70293864