Написать программу заполнить массив из 15 элементов случайными числами (-20; 80) посчитать сумму всех элементов массива посчитать количество отрицательных элементов

schabuneva schabuneva    3   18.05.2019 10:00    17

Ответы
влщчцдыо влщчцдыо  11.06.2020 16:14

const

  n = 15;

var

  a:array[1..n] of integer;

  i, Count, Summ:integer;

begin

  randomize;

  Count := 0;

  Summ := 0;

  for i := 1 to n do

  begin

    a[i] := random(101) - 20;

    write(a[i], ' ');

    inc(Summ, a[i]);

    if a[i] < 0 then

      inc(count);

  end;

  writeln;

  writeln('Summ = ', Summ);

  writeln('Count = ', count);

  readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика