Написать программу, язык pascal. ввести целое положительное число трехзначное число n. разбить это число на разряды (найти число сотен, десятков и единиц). найти сумму разрядов числа n

кирилл2124 кирилл2124    3   03.09.2019 04:10    1

Ответы
Valensia59 Valensia59  26.08.2020 14:08
Program razrad;
  var n,a,b,c,s: integer;
begin
  write('введите положительное трехзначное число - '); readln(n);
  a:=n mod 10; {последняя цифра}
  b:=(n div 10) mod 10; {средняя цифра}
  c:=n div 100; {первая цифра}
  writeln('сотен - ', с, ', десятков -',b,', единиц - ',a);
  s:=a +b+c:
  writeln('сумма цифр числа - ',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика