Написать программу, выводящую на экран все двузначные числа, сумма которых равна 10 и нечетные числа. (цикл For)

Topxic Topxic    2   22.10.2020 23:56    4

Ответы
akkiekim akkiekim  21.11.2020 23:56

Очень странно: какие это двузначные числа, сумма которых равна 10 Может, сумма цифр равна 10? Pascal:

var

  i: integer;

begin

 for i := 10 to 99 do

 begin

   if ((i div 10) + (i mod 10) = 10) then

     WriteLn(i, ' - сумма цифр равна 10');

   if ((i mod 2) = 1) then

     WriteLn(i, ' - нечетное число');

 end;

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика