Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов

ulpashkova ulpashkova    3   21.08.2019 09:20    5

Ответы
ангелок76 ангелок76  05.10.2020 09:02
Program n1;
const n=6;
var a: array [1..n] of integer;
i,sum: integer;
begin
sum:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
end;
writeln('вывод отриц. элементов: ');
for i:=1 to n do
if a[i]>=0 then sum:=sum+a[i] else writeln(a[i]);
writeln('сумма положительных: ',sum);
end.
Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов
ПОКАЗАТЬ ОТВЕТЫ
Zaharza1 Zaharza1  05.10.2020 09:02
Вроде так, это бэйсик
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика