Написать программу вывести элементы массива [90, 20, -40, -9, 0, 6, 12], которые меньше среднего арифметического всех элементов этого массива # код с урока # нахождение суммы положительных элементов массива # объявим массив (лист) mas = [90, 20, -40, -9, 0, 6, 12] # объявим переменную, которая будет копить сумму sum = 0 # узнаю длину массива l = len(mas) # объявляю индекс для прохода по массиву i = 0 # делаю обход массива, пока индекс меньше длины массива while i 0: sum += mas[i] i+=1 # вывести результат на экран print('сумма положительных элементов массива =', sum)

astashkin222 astashkin222    1   19.03.2019 21:25    2

Ответы
Леголаска Леголаска  26.05.2020 05:47

a=[90, 20, -40, -9, 0, 6, 12]

mid=sum(a)/len(a)

for i in a:

 if i<mid:

     print(I)

s=0

a=[90, 20, -40, -9, 0, 6, 12]

for i in a:

if i>0:

  s+=i

print(s)

ПОКАЗАТЬ ОТВЕТЫ
AlisaSerikh AlisaSerikh  26.05.2020 05:47

mass = [90, 20, -40, -9, 0, 6, 12]

sr = sum(mass) / len(mass)

for i in range (5):

   if  mass[i]<sr:

       print(mass[i])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика