Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры. вид экрана: введите числа. для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67 с циклом while do напишите а не с repeat untill

Полинаed Полинаed    3   18.05.2019 16:10    9

Ответы
морпехРФ морпехРФ  11.06.2020 22:17

program z8;
uses crt;
var
i,k,n:byte;
s:integer;
sa:real;
begin
clrscr; i:=1;
writeln('Для завершения последовательности нажмите ноль');
while i>0 do begin
read(i);

write(' '); {- нужен, чтобы числа нормально смотрелись}
if i>0 then begin
k:=k+1;
s:=s+i;
end; end;
sa:=s/k;
write('введено чисел:',k,' сумма чисел:',s,'Среднее арифметическое:',sa:4:2);
readkey
end.

ПОКАЗАТЬ ОТВЕТЫ
vanyalebedev1248 vanyalebedev1248  11.06.2020 22:17

uses crt;
var a,n,s,ar:real;
begin
a:=1;
n:=-1;
s:=0;
writeln('Введите последовательность чисел: ');
while a<>0 do begin
read(a);
n:=n+1;
s:=s+a;
end;
ar:=s/n;
writeln('Введено чисел: ',n);
writeln('Сумма чисел: ',s);
writeln('Среднее арифметическое: ',ar);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика