написать программу, вычисляющую сумму бесконечного ряда с заданной точностью. в Pascal. Если можно, то с минимальными объяснениями.


написать программу, вычисляющую сумму бесконечного ряда с заданной точностью. в Pascal. Если можно,

DLM1 DLM1    2   30.03.2021 22:38    14

Ответы
альбина330 альбина330  29.04.2021 22:43

function factorial(x:real): real;

begin

   if x = 1 then factorial := 1

   else factorial := x * factorial(x-1);

end;

function F(n:integer; x:integer): real;

begin

   if n = 1 then F:=3*sqr(x)/2

   else F:=exp(n*ln(3))*exp(2*n*ln(x))/factorial(2*n) + F(n-1, x);

end;

var n,x:integer;

begin

   x := 2;

   n := 50;

   write(F(n,x):0:2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика