Написать программу вычисляющую чётность нечётность цифр и так чтобы при вводе нуля писалось что так делать нельзя !

ismailovu5 ismailovu5    3   27.09.2019 18:30    1

Ответы
NekitGame225 NekitGame225  08.10.2020 23:09

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n:=Abs(ReadInteger('Введите целое число:'));

 if n.IsOdd then Println('Число нечетное')

 else

   if n=0 then Writeln('Ноль вводиить нельзя')

   else Println('Число четное')

end.

ПОКАЗАТЬ ОТВЕТЫ
MariaVay000 MariaVay000  08.10.2020 23:09

#include <iostream>



int main()

{

   int x;

   std::cout << "Введите число, которое нужно проверить: ";

   std::cin >> x;

   

   if(x == 0)

       std::cout << std::endl << "Нельзя писать такое число!";

   else if(x % 2 == 0)

       std::cout << std::endl << "Четное";

   else if(x % 3 == 0 || x == 1)

       std::cout << std::endl << "Нечетное";

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика