Написать программу вычисления суммы всех 3-х значных чисел, у которых сумма цифр кратно числу а.нахождения суммы цифр 3х значного числа написать подпрограмму. ( с функцией) i = от 100 до 999 i=326 x = i div 100 y=i div 10 mod 10 z= i mod 10 s= x+y+z 2)определить значение переменной после выполнения фрагмента алгоритма: s: =24; m: =3456; while s> 10 do begin m: =m mod 10; s: =s-m end; s: =s+m; write(m); мне нужно именно решение, а не тупо !

arcadig01 arcadig01    1   25.05.2019 06:00    5

Ответы
Lord222435 Lord222435  21.06.2020 06:27
Function T1(b:integer):integer;
begin
T1:=b mod 10 +(b div 10)mod 10+((b div 10)div 10)mod 10;
end;
Var
i,a,S:integer;
begin
S:=0;
For i:=100 to 999 do
  if T1(i) mod 3 =0
  then S:=S+T1(i);
writeln(S);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика