Написать программу вычисления суммы: sin x + sin 2x + sin 3x + + sin nx

Iliyz Iliyz    3   29.07.2019 15:20    9

Ответы
xnxnxnxnx xnxnxnxnx  03.10.2020 16:40
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var x:=ReadReal('x=');
  var s:=0.0;
  for var i:=1 to ReadInteger('n=') do s+=sin(i*x);
  Writeln('s=',s)
end.

Тестовое решение
x= 0.543
n= 15
s=2.79048740821036
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика