Написать программу вычисления суммы целых чисел от 1 до n, запрашиваемого с клавиатуры. pascal abc

Кирилл62а Кирилл62а    2   26.09.2019 21:00    3

Ответы
agm7132 agm7132  21.08.2020 16:25
Var
  i, n: integer;
  sum: longint;
begin
write('n = ');
readln(n);
for i := 1 to n do sum := sum + i;
writeln('Сумма чисел от 1 до ', n , ' = ', sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
nastyamagiao nastyamagiao  21.08.2020 16:25
Var
  s,n:integer;
begin
  Write('Введите n:');
  Readln(n);
  s:=n+(n*(n-1)) div 2; { сумма арифметической прогрессии }
  Writeln('Сумма чисел от 1 до ',n,' равна ',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика