Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу признака конца.

vasilinabv vasilinabv    2   11.08.2019 07:40    3

Ответы
Bartova2006 Bartova2006  04.10.2020 10:52
Var a,b,k,s:integer;
 Begin 
writeln ('Сколько всего будет чисел?');
readln (a);
writeln ('Вводите числа по одному через enter');
for b:=1 to a do
begin
readln (k);
 if k>0 then S:=S+k;
end;
writeln(S/a); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика