Написать программу вычисления модуля произведения отрицательных чисел, если индекс ячейки нечётное число.

KOJIOCOK KOJIOCOK    1   27.04.2020 18:23    2

Ответы
Школьник5432467 Школьник5432467  13.10.2020 23:28

Program Primer;

var A: Array[1..20] Of Integer;

     i, n, s, p: Integer;

begin

    write ('n=');  

    readln (n);

    for i:=1 to n do readln (A[i]);   {ввод массива}                 s:= 0;  p:=1;

    for i:=1 to n do   {обработка массива}

    if (A[i] mod 2 <>0) and (A[i] mod 3 = 0) then

     begin

         s:=s+A[i];  

         p:= p*A[i];

     end;

    writeln ('s=', s, 'p=', p);

    readln;

    end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика