Написать программу вычисления количества ненулевых элементов одномерного массива. в c++

проблемка4 проблемка4    1   30.07.2019 01:10    6

Ответы
Леша119 Леша119  27.09.2020 16:47
#include <iostream>
using namespace std;

int main(){
    int ar[10];
    int k=0;
    for(int i=0;i<10;i++){
            cin>>ar[i];
            if(ar[i]!=0)
              k++; 
             }
     cout<<k;
     cin.get();
     cin.get();
}

Пример ввода:
1
0
0
0
0
1
1
1
1
Пример вывода:
6
ПОКАЗАТЬ ОТВЕТЫ
rgfheh rgfheh  27.09.2020 16:47
#include <cstdlib>#include <iostream> using namespace std; void MassNullEllement(int *Mass){     int KolEl = 0 ;     for(int a=0;a<5;a++){        if(Mass[a]!=0){KolEl++;}        }     cout<<"amount element not equal zero = "<<KolEl<<"\n";    } int main(int argc, char *argv[]){    int Massiv[5];    for(int b=0;b<5;b++){            cout<<"Enter "<<b<<" element - ";
cin>>Massiv[b];           }   MassNullEllement(Massiv);    system("PAUSE");    return EXIT_SUCCESS;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика