Написать программу, вводящую с клавиатуры целые числа и вычисляющую их сумму до тех пор, пока эта сумма не станет больше 1000. В этом случае программа должна напечатать вычисленную сумму и завершиться. (С программы Java)

Аня20171502 Аня20171502    2   30.10.2020 12:01    3

Ответы
fegancev fegancev  29.11.2020 12:02

import java.util.Scanner;

public class Main{

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       int sum = 0, x;

       while(sum <= 1000){

           x = sc.nextInt();

           sum = sum + x;

       }

       System.out.println(sum);

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика