Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое. !

KADANCHUK KADANCHUK    3   19.05.2019 21:40    2

Ответы
Fidan054 Fidan054  13.06.2020 03:53

var sum,n,temp:integer;

begin

   sum:=0;

   n:=0;

   readln(temp);

   while(temp<>0) do begin

      inc(n);

      sum:=sum+temp;

      readln(temp);

   end;

   writeln('Sum = ',sum,'; Ave = ',sum/n)

   end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика