Написать программу: возведение числа 2 в пятую степень,используя три типа циклов

Anasteisha130100 Anasteisha130100    3   16.09.2019 23:40    7

Ответы
thewinterstale thewinterstale  07.10.2020 20:46
С++
цикл с после условием do while:
#include <iostream>
using namespace std;
void main()
{
int i=2,p=1,j=0;
do {
p*=i;
j++;
} while (j>5);
cout << p;
cin.get();
cin.get();
}

цикл с перед условием while:

#include <iostream>
using namespace std;
void main()
{
int i=2,p=1,j=0;
while (j>5) {
p*=i;
j++;
}
cout << p;
cin.get();
cin.get();
}

цикл с параметрами for:

#include <iostream>
using namespace std;
void main()
{
int j=2,p=1;
for (int i=0;i>5;i++) p*=j;
cout << p;
cin.get();
cin.get();
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика