Написать программу, , . вид экрана: введите числа. для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67

ритуля51 ритуля51    3   17.05.2019 22:10    3

Ответы
AliskaLao16 AliskaLao16  11.06.2020 03:29

 

 

 

В задании не сказанно что числа целые  поэтому тип c: real;

 

 Program SumAndAvg;  

 Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write('Input Numbers:');
n:=0;s:=0;
repeat

read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;

until (c=0);
writeln('Numbers count =',n);
writeln('Summa =',s:2:2);
writeln('Average Value=',s/n:2:2);
readkey;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика