Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. количество очков, полученных в ходе игры, может быть равно 1, 2 или 3. после окончания игры выдать итоговое сообщение и указать номер команды-победительницы. окончание игры условно моделировать вводом количества очков, равного нулю. на паскаль

чичекадиль чичекадиль    1   08.06.2019 12:20    6

Ответы
Миксеры Миксеры  07.07.2020 17:23
var
  commands: array [1..2] of byte;
  buf: string;

begin
  writeln('Формат ввода: (№ комманды)(пробел)(очки)');
  writeln('Например:     1 3');
  writeln('№ О');
  repeat
    readln(buf);
    if buf = '0' then break;
    commands[integer.Parse(buf[1])] += byte.Parse(buf[3]);
  until false;
  
  writeln(String.Format('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2] ? 1 : 2, max(commands[1], commands[2])));
end.
ПОКАЗАТЬ ОТВЕТЫ
znikitai znikitai  07.07.2020 17:23
Полный код не влез, в 2 комента вставил
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика