Написать программу в turbo pascal. напишите программу генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10; 20]. вычислить сумму положительных элементов последовательности, порядковые номера которых нечетны.

2003kate2003kate2003 2003kate2003kate2003    2   27.07.2019 23:40    3

Ответы
poliaprokopets poliaprokopets  25.09.2020 14:59
Var a : array[1..50] of integer;   
      sum, i : integer;
begin
randomize;
for i := 1 to 50 do begin 
      a[i] := random(31)-10; 
      if (a[i] > 0) and (i mod 2 <> 0) then   
            sum := sum + a[i]; 
end;
write(sum)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика