Написать программу в ! составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. замена выполняется, начиная с заданной позиции строки.

филькатв филькатв    1   19.06.2019 14:30    5

Ответы
MintMartini MintMartini  15.07.2020 20:00
Var
k:integer;
s:string;
procedure Zamena(var ss:string; p:integer);
var
i:integer;
begin
for i:=p to length(ss) do
begin
if ss[i]='1' then ss[i]:='0' else
if ss[i]='0' then ss[i]:='1';
end;
end;
begin
writeln('Введите строку: ');
readln(s);
writeln('Введите позицию с которой начинать замену: ');
readln(k);
Zamena(s,k);
writeln('Измененная строка: ',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика