Написать программу в с ++ составить программу обработки матрицы размерности n*m. выполнить программу для n=3,m=4.заполнение массива произвести с датчика случайных чисел. в программе предусмотреть вывод исходной матрицы и полученной. по невозрастанию значений небольших элементов строк.( упорядочить(переставить)столбцы массива)

marine25 marine25    2   31.07.2019 14:30    0

Ответы
сюзи27 сюзи27  03.10.2020 18:50
//Dev-C++ 4.9.9.2

#include <ctime>
#include <iostream>
using namespace std;

#define n 3
#define m 4

int main(){
    srand(time(NULL));
    int ma[n][m];
    int arsub[n];
    int max=-1;
    cout<<"Matrix:"<<endl;
    for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                    ma[i][j]=rand()%50;
                    cout<<ma[i][j]<<' ';
                    if(ma[i][j]>max)max=ma[i][j];}
            cout<<endl;
            arsub[i]=max;
            max=-1;}
    for(int i=0;i<n-1;i++)
     for(int j=i+1;j<n;j++)
                    if(arsub[j]>arsub[i]){
                     for(int z=0;z<m;z++)
                     swap(ma[i][z],ma[j][z]);
                     swap(arsub[j],arsub[i]);}
     cout<<"Final matrix:"<<endl;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++)
                    cout<<ma[i][j]<<' ';
            cout<<endl;}
     cin.get();
     cin.get();
  return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика