Написать программу в с++ составить программу для выполнения указанного ниже ,используя оператор множественного ветвления. по номеру класса выдать название школьной ступени.

ladyL6667 ladyL6667    3   31.07.2019 14:30    4

Ответы
Диля175 Диля175  03.10.2020 18:42
//Pascal ABC.NET 3.1 сборка 1219

Var
 a:integer;
begin
readln(a);
case a of
1..4:writeln('Младшая школа');
5..9:writeln('Средняя школа');
10..11:writeln('Старшая школа')
else writeln('Не класс');
end;
end.

//Dev-C++ 4.9.9.2

#include <iostream>
using namespace std;

int main(){
    setlocale(LC_CTYPE,"Russian");
    int a=0;
    cin>>a;
    switch(a){
              case 1:
              case 2:
              case 3:
              case 4:
                   cout<<"Младшая школа";
                   break;
              case 5:
              case 6:
              case 7:
              case 8:
              case 9:
                   cout<<"Средняя школа";
                   break;
              case 10:
              case 11:
                   cout<<"Старшая школа"; 
                  break;
              default:
                      cout<<"Не класс";
              break;
}
    cin.get();
    cin.get();
    return 0;
}

Пример ввода:
11
Пример вывода:
Старшая школа
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика