Написать программу в с++ составить программу для графического изображения делимости чисел от 1 до n. в каждой строке надо напечатать очередное число и столько символов “+”, сколько делителей у этого числа. например, если n = 4, то на экране должно быть напечатано: 1+ 2++ 3++ 4+++

avalak99 avalak99    3   09.09.2019 13:00    11

Ответы
влад2220 влад2220  07.10.2020 03:12
#include <iostream>
int main() {
  int n = 0;
  std::cin >> n;
  for (int i = 1; i <= n; ++i) {
    std::cout << i;
    for (int j = 1; j <= n; ++j) 
      if (i % j == 0)
        std::cout << "+";
      std::cout << std::endl;
  }
  return 0;
}

Пример ввода: 
5

Пример вывода:
1+
2++
3++
4+++
5++
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика