Написать программу в с++ описать функцию otr(ax,bx,ay,by) вещественного типа находящую длину отрезка ab на плоскости по координатам его концов |ab|=sqrt((ax-bx)^2+(ay-by)^2 )(ax,ay,bx,by)- вещественны параметры) с этой функции найти длины отрезков ab,ac,ad, если с клавиатуры заданы координаты точек, a,b,c,d.

tikmehr tikmehr    2   01.10.2019 14:20    10

Ответы
Ffaafafa Ffaafafa  09.10.2020 07:54

#include <iostream>

#include <cmath>

using namespace std;


double Otr(double Ax, double Bx, double Ay, double By) {

return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));

}


int main() {

double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;

cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;

cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;

cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;

cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;

return 0;

}


Написать программу в с++ описать функцию otr(ax,bx,ay,by) вещественного типа находящую длину отрезка
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика