Написать программу в с++ натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая это самое число. например, число 6 является совершенным (1+2+3 = 6). найти все совершенные числа, меньшие 100 000.

Андрей3482 Андрей3482    3   09.09.2019 13:00    12

Ответы
mamazomdi mamazomdi  07.10.2020 03:11
#include <iostream>
using namespace std;

int main(){
    int s;
    for (int i=2; i<=100000; i++){
    s = 1;
    for (int j=2; j<=i/2; j++)
    if (i % j == 0) s+=j;
    if (s == i)
    cout << i << " ";
    }
    return 0;
}

Результат:
6 28 496 8128
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика