tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу в с++ .
Написать программу в с++ . надо. в произвольном тексте программа выводит самое короткое слово.
kvpopochku
3 12.07.2019 05:50
2
Ответы
Лерааникина
18.09.2020 08:48
//самое короткое слово
#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int main(int argc, char** argv) {
int i=0,j=0,l=0;
char st[200];
char ch=' ';
cout<<" string: "; gets(st); cout<<endl;
string mins;
int mn,bgmn,emn,tek;
mn=strlen(st); bgmn=0;
while (true) {
while ((st[j]!=ch) and (j<strlen(st))) j++;
tek=j-l;
for (int i=l; i<j; i++)
{ if (tek<mn) { mn=tek; bgmn=l; emn=j-1; } }
if (j==strlen(st)) break;
j++; l=j;
}
//запись строки
for (int i=bgmn; i<=emn; i++) mins=mins+st[i];
cout<<"short word: "<<mins<<endl<<endl;
system("pause");
return(0);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lilija647
03.04.2019 17:29
При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий символы из набора: а, в, c, d, е, f, g, h, k, а...
dariadamyak27
03.04.2019 17:26
1. существует 16 логических устройств, имеющих два входа (16 логических функций от двух переменных). реализуйте их комбинационные схемы с логических элементов и, или,...
Каримовка
03.09.2019 07:10
Вэлектронной таблице значение формулы =сумм(в2: в4) равно 6. чему равно значение формулы =срзнач(в2: в5), если значение ячейки в5 равно 14?...
OOONIMOOO
07.05.2020 21:34
Решать только встроенными функциями. Начало таблицы прикрепляю. 1. Сколько учеников сдали экзамен по математике ниже, чем на отметку а экзамены по русскому и иностранному...
taukebai2002
07.05.2020 21:33
1. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?i:=1;whilei =... dobeginwriteln( Привет! ); i:=i+1end;2. Сколько раз будет выполнен...
настя123настя1
07.08.2019 13:30
Написать программу вычисления значения функции у=1/х.для х от -1 до +2 с шагом в 0.2...
Halimali10
07.08.2019 13:30
Продолжи письменно рассказ жили были клавиатура,монитор, память и процессор.жили они дружно пока не возник спор, кто из них...
kjmhngbfv
07.08.2019 13:30
Перезагрузка windows 10 , у мня есть проблема по поводу windows 10 . я перезагрузила компьютер и у меня появилось окно перезагрузка она уже так стоит где-то 30 минут...
lera14mansurova
04.12.2019 18:15
Напишите программу в паскале найдите квадратный корень из 16, квадрат 25, модуль -10....
Данана1
04.12.2019 18:15
Как записать программу в паскале? робот умеет ходить только вперед,назад,поворачивать влево,вправо от цифры 1 до цифры 6....
Популярные вопросы
Определи по рисунку проекцию перемещения тела из точки A в точку...
1
Вычислить массу сульфата меди, если химическое количество атомов...
3
яку роль відіграє інтернет в мовній і мовленневій освіті? Як він...
1
Бас әріппен жазылатын күрделі атауларға мысалдар жазыңдар...
1
Будласка (6,3:(-9/20)-2,6:(-1/20))*-4/19)-0,6:(0,36)...
1
Что за слово 1 БУКВА ПРОПУЩЕНА заре_ли...
1
, какая фигура не может быть графиком функции...
2
3) Найдите котангенс углаАОВ...
2
Sqrt(2x^2-x-5)+x=0 11 КЛАСС...
1
5 1/6 × 2 - 2 11/12 : 1 5/9 =...
3
#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int main(int argc, char** argv) {
int i=0,j=0,l=0;
char st[200];
char ch=' ';
cout<<" string: "; gets(st); cout<<endl;
string mins;
int mn,bgmn,emn,tek;
mn=strlen(st); bgmn=0;
while (true) {
while ((st[j]!=ch) and (j<strlen(st))) j++;
tek=j-l;
for (int i=l; i<j; i++)
{ if (tek<mn) { mn=tek; bgmn=l; emn=j-1; } }
if (j==strlen(st)) break;
j++; l=j;
}
//запись строки
for (int i=bgmn; i<=emn; i++) mins=mins+st[i];
cout<<"short word: "<<mins<<endl<<endl;
system("pause");
return(0);
}