Написать программу, в результате работы которой будут заполнятся и выводится в строчку на экран целочисленный массив c из 7 элементов. значения элементов массива находятся в диапазоне от −10 до 10 и заполняются случайным образом. выполнить: поиск наибольшего сортиовать по возрастанию

tanygina067 tanygina067    2   18.08.2019 17:10    4

Ответы
яна1766 яна1766  08.09.2020 19:17
#include <iostream>
#include <algorithm>
#include <ctime>
using namespace std;
const int ARRAY_SIZE = 7;
int c[ARRAY_SIZE];

void print_array();

int main(int argc, char *argv[])
{
    srand ( time(NULL)  );
    cout << "---   ЗАПОЛНЕНИЕ МАССИВА  ---\n";
    for (int i = 0; i < ARRAY_SIZE; ++i) {
        c[i] = rand() % 21 - 10;
        cout << c[i] << ' ';
    }
    cout << "\n---    МАССИВ ЗАПОЛНЕН    ---\n";
    cout << "---   ПОИСК НАИБОЛЬШЕГО   ---\n";
    int max = c[0];
    for (int i = 0; i < ARRAY_SIZE; ++i) {
        if (c[i] > max) max = c[i];
    }
    cout << "---    ПОИСК ЗАВЕРШЁН     ---\n"
         << "Наибольшее: " <<   max   << '\n'
         << "---   НАЧАЛО СОРТИРОВКИ   ---\n";
    sort(c, c + ARRAY_SIZE);
    cout << "---  МАССИВ ОТСОРТИРОВАН  ---\n";
    print_array();
    return 0;
}

void print_array() {
    cout << "---     ВЫВОД НА ЭКРАН    ---\n";
    for (int i = 0; i < ARRAY_SIZE; ++i) {
        cout << c[i] << ' ';
    }
    cout << "\n---      КОНЕЦ ВЫВОДА     ---\n";
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика