Написать программу в решить с использованием процедур. указать выделенные , решаемые процедурами. последовательность хейеса. дано натуральное число n (n > 1). если оно чётно, то его делят на 2, иначе умножают на 3 и прибавляют 1. если полученное число не равно 1, то действия повторяются до тех пор, пока не получится 1. вершиной называют наибольшее число в получающейся последовательности. для заданного n построить указанную последовательность, указать её вершину и количество шагов

Fjkskdnxk Fjkskdnxk    3   31.07.2019 10:40    4

Ответы
viparistocrate viparistocrate  28.09.2020 14:54
//Pascal ABC.NET 3.1 сборка 1219

Var
 k,n,max:integer;

 procedure hase(var k,n,max:integer); //сама последовательность
 begin
  if not(odd(n)) then n:=n div 2 else n:=n*3+1; //условие про чётность
  writeln(n); //вывод нового члена последовательности
  inc(k); //увеличение значения счётчика шагов
  if max<n then max:=n; //поиск вершины
 end;

  procedure start(var k,n,max:integer); //название процедуры намекает
 begin
  readln(n);
  k:=0;
  writeln('Seq:');
  max:=integer.MinValue;
  while n<>1 do
  hase(k,n,max);
  writeln('Шаги:',k);
  writeln('Вершина:',max);
 end;
 begin
 start(k,n,max);
end.
Пример ввода:
6
Пример вывода:
Seq:
3
10
5
16
8
4
2
1
Шаги:8
Вершина:16
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика