Написать программу в python

задан двумерный массив а из 3-х строк и 5-и столбцов. составить программу, которая организует одномерный массив, каждый элемент которого есть количество положительных элементов исходного массива в столбце. вычислить произведение элементов полученного массива.

syngalox420 syngalox420    1   13.12.2019 16:09    10

Ответы
Kate905 Kate905  10.10.2020 20:27

Объяснение:

Обозначим заданный двумерный массив через A, искомый одномерный - через В, произведение всех элементов этого массива - M. Тогда:

B=[ ]

M=1

for i in range(5):

   n=0

   for j in range(3):

       if A[ j ][ i ]>0:

           n+=1

   B.append(n)

   M*=n

print(B,M)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика