написать программу в Python Дан целочисленный массив из 30 элементов. Элементы массива могут принимать
целые значения от -300 до 300 включительно. Напишите на одном из языков
программирования алгоритм, позволяющий найти и вывести количество пар элементов
массива, сумма которых нечетна, а произведение больше 50. Под парой подразумевается
два подряд идущих имеют элементов массива. Исходные данные объявлены так, как
показано ниже на примерах для некоторых языков программирование и естественного
языка. Запрещается использовать переменные, не описанные ниже, но разрешается не
использовать некоторые из описанных переменных.


написать программу в Python Дан целочисленный массив из 30 элементов. Элементы массива могут принима

МозгиДемона МозгиДемона    3   17.12.2020 16:47    9

Ответы
Qaswe1 Qaswe1  16.01.2021 16:48

from random import randint  

N = 30

k = []

j = 0

for i in range(N):    # автоматически заполняем массив на 30 элементов

   k.append(randint(-300, 300))   # числами от -300 до 300

print(k)

print("")

# прогоняем пары элементов на соответствие условиям задачи

for i in range(N):      

   if i%2 != 0:

       if ((k[i] + k[i-1])%2 != 0) & ((k[i] * k[i-1]) > 50):  

           print(str(k[i-1]) + " , " + str(k[i]))

           j += 1

print("")

print(j)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика