Написать программу. в программу вводится n чисел, величину n задаёт пользователь, а также числа вводятся подряд. 1.найти сумму введённых чисел. 2.количество чисел равных 0. 3.найти максимум и минимум среди введённых чисел. нужно на языке с. .

anonim000002 anonim000002    3   13.08.2019 02:10    2

Ответы
domka123456789 domka123456789  04.10.2020 14:49
Крч вот на паскале, на Си не могу, сорь

program ;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
    writeln('Введите количество чисел');
    readln(n);
    b:=0;
    for i := 1 to n do
        readln(A[i]);
    for i := 0 to (n) do
        b := b+ A[i];
    write('Это сумма ');
    writeln(b); // Это сумма.
    b:=0;
    for i := 1 to (n) do
    begin
        if A[i] = 0 then
            b := b+1
    end;
    write('Это количество нулей ');
    writeln(b) ;// это количество нулей
    b:= -1001;
    for i := 1 to (n) do
    begin
        if A[i] > b then
            b := A[i]
    end;
    write('Это максимальное число ');
    writeln(b); // Это максимальное число
        b:= 1001;
    for i := 1 to (n) do
    begin
        if A[i] < b then
            b := A[i]
    end;
    write('Это минимальное число ');
    writeln(b) // Это минимальное число
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика