Написать программу в питоне через списки(только через списки, никак иначе) дать подробное пояснение к программе


Написать программу в питоне через списки(только через списки, никак иначе) дать подробное пояснение

oladushek2002oy6bqn oladushek2002oy6bqn    2   16.06.2021 22:49    0

Ответы
sirzikova sirzikova  16.07.2021 23:52

import random

#если нужен ручной ввод - matrix=[[int(input(str(i+1)+" группа " + str(x+1) + " курса: ")) for i in range(6)] for x in range(5)]

matrix=[[random.randint(1,26) for i in range(6)] for x in range(5)]

print(matrix) #чисто для проверки, можно стереть

#запись промежуточных переменных для вычисления минимума

minimum=1000

minimum1=minimum

minimum_grop_list=[]

for i in range(5): #главный цикл, который идет по курсам

   if sum(matrix[i])<minimum: #суммирует количество людей во всех группах курса и ищет наименьшее

       minimum=sum(matrix[i])

       minimum_year=i+1

   minimum2=1000 #тут переменная с каждым курсом перезаписывается для того, чтоб искать наименьшее в каждом из курсов

   for x in range(6): #цикл по курсу, перебирает группы

       if matrix[i][x]<minimum2: #поиск наименьшего в курсе

           minimum2=matrix[i][x]

           minimum_group1=x+1

       if matrix[i][x]<minimum1: #поиск самой наименьшей группы

           minimum1=matrix[i][x]

           minimum_group=x+1,i+1

   minimum_grop_list.append(minimum_group1)

print("a)",minimum_year) #выводит курс

print("б)",*minimum_group) #выводит номер группы, потом курс

print("в)", *minimum_grop_list) #выводит наименьшие группы в каждом из курсов

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика