Написать программу в паскале. задано натуральное число n (n ≤ 9999). определить количество цифр числа n^2.

17312 17312    2   01.09.2019 23:40    2

Ответы
alexsashinav alexsashinav  06.10.2020 10:43
Первый

Var n:longint;
Begin
Write('n = ');ReadLn(n);
n:=n*n;
if frac(Ln(n)/Ln(10)) > 0 then WriteLn(int(Ln(n)/Ln(10))+1)
else WriteLn(Ln(n)/Ln(10))
End.

Второй

Var
   n,k:longint;
Begin
Write('n = ');ReadLn(n);
k:=0;
n:=n*n;
While n > 0 do
   Begin
   k:=k+1;
   n:=n div 10
   End;
WriteLn(k);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика