Написать программу в паскале: задан список участников соревнований по бегу и их результаты. расположите результаты и фамилии участников в соответствии с местом.

Васютка3333 Васютка3333    1   19.07.2019 13:50    5

Ответы
мрамар мрамар  03.10.2020 08:00
//Pascal ABC.NET v3.1 сборка 1172

type
 re=Record
  name:string;
  res:integer;
 end;

 Const
 n=3;

Var
 ar:array[1..n] of re;
 i,j,c:integer;
 cs:string;
begin;
for i:=1 to n do
 begin
  write('Введите имя участника №',i,':');
 readln(ar[i].name);
  write('Введите результат участника №',i,':');
 readln(ar[i].res);
 end;
 for i:=1 to n-1 do
  for j:=i to n do
  if ar[i].res>ar[j].res then
   begin;
   c:=ar[i].res;
   ar[i].res:=ar[j].res;
   ar[j].res:=c;
   cs:=ar[i].name; 
  ar[i].name:=ar[j].name;
   ar[j].name:=cs;
   end;for i:=1 to n do
writeln(i,' ',ar[i].name,' ',ar[i].res);
end.

Пример ввода:
Двачевская
23
Персунов
22
Хацуне
3
Пример вывода:
1 Хацуне 3
2 Персунов 22
3 Двачевская 23
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика